Viber connectivity issues
Incident Report for TelecomsXChange
Resolved
Viber issues have now been resolved and calls are connecting fine now, you may continue sending traffic to Viber in full Swing.
Posted Jan 15, 2019 - 21:57 UTC
Identified
We have identified connectivity issues via seller: VIber.
Posted Jan 15, 2019 - 21:57 UTC