Columbia Low ACD - Seller: TCXC Route: TDM
Incident Report for TelecomsXChange
Resolved
We have manually tested and no issues were found with quality, seems that some traffic profile causing low ACD.
Posted Oct 31, 2018 - 20:53 UTC
Investigating
We have been informed about a low ACD via Columbia Mobiles via Seller: TCXC Route: TDM, our team is currently manually testing and investigating this matter.
Posted Oct 31, 2018 - 20:03 UTC