Data Processing Delays - Reporting Tools Affected
Incident Report for TelecomsXChange
Resolved
The issue has now been fixed and reporting tools has caught up with the data processing systems.
Posted Mar 28, 2018 - 16:05 UTC
Investigating
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Mar 28, 2018 - 15:56 UTC