Bhaoo Audio Loop - Saudi Arabia CLo
Incident Report for TelecomsXChange
Resolved
This incident has been resolved.
Posted Mar 15, 2019 - 23:48 UTC
Update
The issue has been escalated to carrier NOC team. We recommend switching this traffic temporarily to seller STC or AirTel which perform smoothly to destination.
Posted Feb 07, 2019 - 11:42 UTC
Identified
We have identified an audio loop issue, callers can hear the callee in an audio loop in the middle of the conversation.
Posted Feb 07, 2019 - 11:37 UTC
This incident affected: Sellers (Bhaoo).