Alert! India Market Rate Increases Tonight.
Incident Report for TelecomsXChange
Resolved
This incident has been resolved.
Posted Feb 14, 2019 - 01:15 UTC
Identified
There is a market rate increase for the destination: INDIA, the termination price has doubled from all carriers on TelecomsXChange, we advise you to process the new rate updates effective tonight.
Posted Feb 13, 2019 - 22:56 UTC
This incident affected: Sellers (Bhaoo, AirTel, TATA, IDT, Vasudev).