Global Billing Increment Change for +882 Thuraya all breakouts
Incident Report for TelecomsXChange
Resolved
This incident has been resolved.
Posted Mar 28, 2019 - 12:51 UTC
Investigating
We are kindly informing you, that starting from 1st of April 2019, the basis of charging for the following network will be sixty (60) second increments with a sixty (60) second minimum:

[ 882 Thuraya all breakouts]

Kindly update your records.
Posted Mar 28, 2019 - 12:50 UTC