UAE DID Numbers - Unexpected Downtime
Incident Report for TelecomsXChange
Update
Due to regulation changes. Please send me the following at the earliest in order for your UAE DIDs service to be restored.

1) Commercial License Copy
2) Authorized Signatory Passport copy
3) Signed & Signed LOI Letter on company letter head.
4) Complete Address, Contact Details for the Authorized Person.
5) Assigned DID Number, range from the provided block.

Please note the DID's will be re-activated upon successful verification by the telecom operator within 24 hours upon submission of all above documents.
Posted 28 days ago. Mar 28, 2019 - 15:34 UTC
Update
We are still working closely with our carrier partner in UAE to get this issue sorted it out as quickly as possible.
Posted 28 days ago. Mar 28, 2019 - 12:49 UTC
Monitoring
Due to ongoing criminal investigation the inbound DID numbers for UAE are currently paused by our carrier partner in UAE. The expected down time of service will be for 48 hours. incase the service is not restored to these numbers within 48 hours our team will be in touch with you to discuss the next steps.
Posted 29 days ago. Mar 27, 2019 - 09:53 UTC