PayPal Payment Error
Incident Report for TelecomsXChange
Resolved
This issue has been resolved successfully, seems like it was a temp issue from PayPal API Endpoint.
Posted Aug 12, 2018 - 02:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 10, 2018 - 23:58 UTC
Identified
There seems to be an issue with PayPal payments (top-ups) for buyers due to some failure coming back from PayPal API. We recommend you fall back to the Stripe option to recharge your account at this time with Credit/Debit Card until this issue is resolved. We'll keep you posted on the progress.
Posted Aug 10, 2018 - 23:57 UTC
This incident affected: Web & Database (PayPal Payments).